Subject: Re: Kerberos 5 and cyrus-sasl
To: Martti Kuparinen <>
From: Johnny C. Lam <>
List: tech-pkg
Date: 12/07/2001 07:43:44
On Fri, Dec 07, 2001 at 11:26:15AM +0200, Martti Kuparinen wrote:
> I want to have Kerberos 5 support in cyrus-sasl but must I really
> have kth-krb4 installed? According to Makefile kth-krb4 is not marked
> as dependency in SunOS...
> Can anyone explain why kth-krb4 is needed in NetBSD? I'm in a K5-only
> domain so I don't need/want K4 support...

The KERBEROS setting in pkgsrc is just an on/off switch, and no longer
differentiates between K4 and K5.  You can certainly try removing the K4
stuff from the cyrus-sasl Makefile.  I wasn't actually able to test any
of the Kerberos builds when I added the cyrus-sasl package, so this is all
uncharted territory.


	-- Johnny Lam <>