Subject: problems compiling KDE2 from source
To: None <,>
From: David Friggens <>
List: tech-pkg
Date: 12/07/2001 16:50:40
Hi, I've got a fresh install of NetBSD 1.5.2 with XFree86 4.1 and I'm unable to get KDE2.2.1 to compile.

It halts during the make of kdelibs2 with this message:

Makefile:679: warning: overriding commands for target `knotify.moc'
Makefile:675: warning: ignoring old commands for target `knotify.moc'
In file included from /usr/pkgsrc/x11/kdelibs2/work/.buildlink/include/libxml/parser.h:576,
                 from /usr/pkgsrc/x11/kdelibs2/work/.buildlink/include/libxml/xmlerror.h:4,
                 from templates.c:18:
/usr/pkgsrc/x11/kdelibs2/work/.buildlink/include/libxml/globals.h:70: syntax error before `xmlGenericErrorFunc'
/usr/pkgsrc/x11/kdelibs2/work/.buildlink/include/libxml/globals.h:217: syntax error before `xmlGenericError'
/usr/pkgsrc/x11/kdelibs2/work/.buildlink/include/libxml/globals.h:217: warning: data definition has no type or storage class
gmake[3]: *** [templates.lo] Error 1
gmake[3]: Leaving directory `/usr/pkgsrc/x11/kdelibs2/work/kdelibs-2.2.1/kdoctools/libxslt'
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/pkgsrc/x11/kdelibs2/work/kdelibs-2.2.1/kdoctools'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/pkgsrc/x11/kdelibs2/work/kdelibs-2.2.1'
gmake: *** [all-recursive-am] Error 2
*** Error code 2

*** Error code 1


It's not a problem with the downloaded file - I've checked that and even tried downloading from another site.
I came across a similar problem in the archives with the solution to uninstall libxml and leave libxml2, but that 
hasn't solved it.

It's not possible it's something to do with gcc or gmake is it?

I decided to give up and just use the precompiled binary for kdelibs-2.1nb1 but that required glut-3.4.1 (specifically)
and I've got glut-3.4.2, depended on by other packages. If I can't figure this out, or find someone else to, I'll have 
to throw in the towel and just use kde1.