Subject: Re: Can't compile openmotif-2.1.30 on -current
To: Rui-Xiang Guo <>
From: Johnny Lam <>
List: tech-pkg
Date: 12/06/2001 08:28:04
Content-Type: text/plain; charset=us-ascii

On Thu, Dec 06, 2001 at 08:11:51PM +0800, Rui-Xiang Guo wrote:
> ./config/imake/imake -I./config/cf  -s ./config/makedepend/Makefile.proto -f ./config/makedepend/Imakefile -DTOPDIR=../.. -DCURDIR=./config/makedepend
> ./config/imake/imake: No such file or directory
> ./config/imake/imake: Cannot exec /usr/libexec/cpp.
>   Stop.
> ./config/imake/imake: Exit code 1.
>   Stop.
> *** Error code 1

Please try the attached patch on your system.  This mirrors changes to
the NetBSD xsrc tree to deal with the new toolchain where /usr/libexec/cpp
doesn't exist by calling "cc -E" instead.  Just save the patch as
pkgsrc/x11/openmotif/patches/patch-ar, and then:

	cd pkgsrc/x11/openmotif
	make makepatchsum
	make clean
	make build

Please let me know if this fixes your problem.  It worked fine on my system
with the old toolchain.


	-- Johnny Lam <>

Content-Type: text/plain; charset=us-ascii
Content-Disposition: attachment; filename=patch-ar


--- config/imake/imakemdep.h.orig	Thu Dec  6 10:54:30 2001
+++ config/imake/imakemdep.h
@@ -265,10 +265,10 @@
 #ifdef _CRAY
 #define DEFAULT_CPP "/lib/pcpp"
-#if defined(__386BSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#if defined(__386BSD__) || defined(__OpenBSD__)
 #define DEFAULT_CPP "/usr/libexec/cpp"
-#if defined(__FreeBSD__)
+#if defined(__FreeBSD__) || defined(__NetBSD__)
 #define USE_CC_E
 #if defined(__sgi) && defined(__ANSI_CPP__)