Subject: build of ap-perl fails with apache6
To: None <>
From: Grant Beattie <>
List: tech-pkg
Date: 11/05/2001 23:16:42
# pkg_info | grep apache6
apache6-1.3.22      HTTP (Web) server with IPv6 support

# cd www/ap-perl; make
cc -DPIC -fPIC -O2 -I/usr/pkg/lib/perl5/5.6.1/sparc-netbsd/CORE -fno-strict-aliasing -I/usr/pkg/include  -DMOD_PERL_VERSION=\"1.25\" -DMOD_PERL_STRING_VERSION=\"mod_perl/1.25\" -I/usr/pkg/include/httpd -DMOD_PERL -DNETBSD -DINET6 -Dss_family=__ss_family -Dss_len=__ss_len -DHAVE_SOCKADDR_LEN -I/usr/tmp/www/apache6/work.sparc/.buildlink/include -O2 -c Connection.c && mv Connection.o Connection.lo
Connection.c: In function `XS_Apache__Connection_remote_addr':
Connection.c:119: incompatible types in assignment
Connection.c: In function `XS_Apache__Connection_remote_ip':
Connection.c:154: structure has no member named `sin_addr'
*** Error code 1

Is ap-perl supposed to work with apache6? If not, should it be listed
as a conflict, or can patches be applied based on which of
apache/apache6 is installed?

I updated ap-perl just before attempting the build.


Get NetBSD:            ``Of course it runs NetBSD.''