Subject: Re: Solved... (was Re: pilot-link.0.9.5 compile failure)
To: None <>
From: Mario Kemper <>
List: tech-pkg
Date: 10/25/2001 19:43:40
Eric Jacoboni <> writes:

> >>>>> "Johnny" == Johnny Lam <> writes:
> Johnny> It's unclear what's wrong as I can't reproduce the problem on
> Johnny> my system.
> Looking at my package database i've noticed that a
> pilot-link-libs-0.9.5nb1 was installed... Don't ask me why: i've only
> tried to install the new pilot-link package so i suspect these libs
> was installed during this process. Seems curious as this build has
> always fail...
> Anyway, i've deinstalled all pilot stuff (old pilot-link-0.9.4, this
> curious pilot-link-libs-0.9.5nb1 and jpilot). Then i've tried to build
> pilot-link again and, you know what? it's ok.
> The problem was related to this pilot-link-libs-0.9.5nb1 silently
> installed, that i've not noticed before.

I suppose that the old pilot-link was the problem, not the libs.
In fact pilot-link depends on pilot-link-libs and should have installed them 

pilot-link-libs installs the libs and headers where pilot-link installs all
the utilities that are not always needed.

magick@bundy:~>pkg_info | grep pilot-link
pilot-link-libs-0.9.5nb1 Libraries for talking to the 3Com Pilot PDA
pilot-link-0.9.5    Tools to talk to the 3Com Pilot PDA

No problem here (rebuilt yesterday to see if i can reproduce the problem).

Mario Kemper