Subject: dependency problem
To: None <>
From: Martti Kuparinen <>
List: tech-pkg
Date: 10/09/2001 14:39:16

I'm having problems with dependencies while updating Fvwm2.
I have the following code in Makefile:

.if defined(FVWM2_USE_GTK) && ${FVWM2_USE_GTK} == "YES"
.include "../../x11/gtk/"
PLIST_SUBST+=   GTK="@comment "

Running "make clean" seems to detect that I want to use gtk.
So far so good.

# FVWM2_USE_GTK=YES make clean clean-depends
===> Cleaning for fvwm2-2.4.3
===> Cleaning for gettext-0.10.35nb2
===> Cleaning for gettext-lib-0.10.35nb1
===> Cleaning for gettext-m4-0.10.35
===> Cleaning for glib-1.2.10
===> Cleaning for gmake-3.79.1
===> Cleaning for libtool-base-1.4.20010614nb3
===> Cleaning for pth-1.4.0
===> Cleaning for readline-4.2
===> Cleaning for perl-5.6.1nb5
===> Cleaning for x11-links-0.4
===> Cleaning for gtk+-1.2.10
===> Cleaning for xpmroot-2.4.3

If I compile this I get GTK as dependency which is expected:

# FVWM2_USE_GTK=YES make all
===> Validating dependencies for fvwm2-2.4.3
=> Checksum OK for fvwm-2.4.3.tar.gz.
=> Checksum OK for fvwm_icons.tgz.
===> Extracting for fvwm2-2.4.3
===> Required installed package xpmroot-2.*: xpmroot-2.4.3 found
===> Required installed package gtk+>=1.2.8: gtk+-1.2.10 found
===> Required installed package gettext-lib>=0.10.35nb1: gettext-lib-0.10.35nb1 found
===> Required installed package glib>=1.2.8: glib-1.2.10 found
===> Required installed package pth>=1.3.2: pth-1.4.0 found
===> Required installed package readline>=2.2: readline-4.2 found
/bin/mkdir -p /work/netbsd/pkgsrc/wm/fvwm2/work/icons

But for some reason "make install" doesn't think gtk is required:

# FVWM2_USE_GTK=YES make install
===> Registering installation for fvwm2-2.4.3
fvwm2-2.4.3 requires installed package readline-4.2
fvwm2-2.4.3 requires installed package xpmroot-2.4.3

This results a missing dependency and wrong PLIST. Any ideas what
could be wrong? I've looked too long at this so maybe I'm blind
for stupid mistakes...


Martti Kuparinen <>              NetBSD - No media hype