Subject: Re: Fvwm 2.4.3 is released (fwd)
To: Tom Spindler <>
From: Martti Kuparinen <>
List: tech-pkg
Date: 10/09/2001 10:30:13
On Mon, 8 Oct 2001, Tom Spindler wrote:

> > Btw, why the hell does fvwm2 now depends on gtk and imlib?
> >
> > It now takes a lot of time to just install X11 and build fvwm2.
> > It is enough that you need to build perl, for one of the dependencies
> > for fvwm2, which needs autoconf.
> It appears they were added by - presumably for the
> FvwmGtk module. I could personally do without it.

I've updated xpmroot and I'm working on fvwm2 right now. Would this
be acceptable before we get fvwm2-gtk etc?

+.if defined(WANT_FVWM_GTK)
+.include "../../x11/gtk/"
+PLIST_SUBST+=   GTK="@comment "
+.if defined(WANT_FVWM_IMLIB)
+.include "../../graphics/imlib/"
+PLIST_SUBST+=   IMLIB="@comment "
 .include "../../audio/rplay/"
 .include "../../devel/readline/"
-.include "../../graphics/imlib/"
-.include "../../x11/gtk/"
 .include "../../mk/"

I'm also one of those who just want a small footprint window manager
without any extra garbage...


Martti Kuparinen <>              NetBSD - No media hype