Subject: mysql-server fails to build with the new toolchain
To: None <>
From: Bernd Ernesti <>
List: tech-pkg
Date: 10/07/2001 22:06:28

I am reinstalling my packages and it worked fine till I tried to build

c++ -DMYSQL_SERVER                      -DDEFAULT_MYSQL_HOME="\"/usr/pkg\""                     -DDATADIR="\"/var/mysql\""                      -DSHAREDIR="\"/usr/pkg/share/mysql\""                   -DHAVE_CONFIG_H -I../mit-pthreads/include                                               -I./../include                  -I./../regex                    -I. -I../include -I.. -I.  -Dunix -Dunix  -O3 -DDBUG_OFF -O2  -fno-implicit-templates -fno-exceptions -fno-rtti -c In function `int mc_sock_connect(int, const sockaddr *, unsigned int, unsigned int)': implicit declaration of function `int select(...)'
*** Error code 1

make: stopped in /home/source/pkgsrc/databases/mysql-server/work.i386/mysql-3.23.39/sql
*** Error code 1

I have no idea what is going on here. I tried to add <unistd.h>, but that didn't fix
the problem.