Subject: Re: kde2 build
To: None <tech-pkg@NetBSD.ORG>
From: Kent Polk <>
List: tech-pkg
Date: 07/13/2001 16:31:54
On 13 Jul 2001 10:05:00 -0500, Chuck Cranor wrote:
> On Sun, Jul 08, 2001 at 01:31:09PM +0200, Tomasz Luchowski wrote:
>> Please cvs update your kdelibs2/Makefile and kdebase2/Makefile and see 
>> it this helps.  I followed suggestion from Johnny C. Lam and added 
>> tried to compile kde2 with this change, though (ETOOSLOWBOX).
> it helped some, but it still does not work:
> gmake[4]: Entering directory `/usr/home/gaoy/netbsd/pkgsrc/x11/kdelibs2/work/kde
> libs-2.1/arts/flow'
> ../../arts/mcopidl/mcopidl -t ../../arts/flow/artsflow.idl
> Shared object "" not found
> gmake[4]: *** [artsflow.h] Error 1
> gmake[4]: Leaving directory `/usr/home/gaoy/netbsd/pkgsrc/x11/kdelibs2/work/kdel
> ibs-2.1/arts/flow'
> gmake[3]: *** [all-recursive] Error 1

This is exactly the same problem I am having with building kde2 as
a result of the new libpng and required upgrades from that.  Nick
has been trying to help me determine what is wrong here.

Initially libltdl wasn't getting built, but somehow I managed to
fix that (don't know what fixed it though). The current problem
referenced above appears to be a buildlink or libtool problem.