Subject: Re: building mesa-apps w/ XFree 4
To: None <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 07/06/2001 08:45:55
On Fri, 6 Jul 2001, Bernd Ernesti wrote:

> On Thu, Jul 05, 2001 at 06:56:30PM -0500, Frederick Bruckman wrote:
> To make it short:
> GLU support was added after 4.0.3 and is now in 4.1.0.

So you're saying there was a window where a "make World" in
/usr/xsrc/xfree/xc would _not_ have installed libGL*, but now it does?

> > > /usr/X11R6/include/GL/glu.h
> It is not installed by pkgsrc, see my first answer from above.

OK. I'm still not understanding how a current XF4 build will install
libGL*, though I haven't tried it. Explain:

fredb@handy-> pwd
fredb@handy-> cpp -dM -E -I./ Imake.tmpl | grep \#define\ Build[GS]
Imake.tmpl:1791: `#include' expects "FILENAME" or <FILENAME>
#define BuildSpeedo YES
#define BuildSyncExt YES
#define BuildGLULibrary (BuildGLXLibrary && HasCplusplus)
#define BuildGLXLibrary (BuildGlxExt && !BuildServersOnly)
#define BuildGlxExt NO
#define BuildGreekFonts YES
#define BuildSpecsDocs NO
#define BuildSpeedoFonts YES
#define BuildShapeExt YES
#define BuildServersOnly NO
#define BuildScreenSaverExt NO
#define BuildServer HasXServer
#define BuildScreenSaverLibrary (BuildScreenSaverExt &&  !BuildServersOnly)

This is seconds after "cvs update -A". It looks to me like
BuildG[Ll].* are all going to be "NO".