Subject: libjpeg, kde and QT problems
To: None <tech-pkg@NetBSD.ORG>
From: Kent Polk <>
List: tech-pkg
Date: 05/29/2001 19:32:25
The recent jpeg pkg changes appear to have bitten me. I tried to
update AbiWord (on a NetBSD 1.4.2 system) to the current version
and that led to basically having to try to rebuild almost my entire
pkg system. I've been trying for several days to rebuild KDE and
I can't get past:

gmake[3]: Entering directory
c++ -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/X11R6/qt1/include  -I/usr/X11R6/include
-O2 -I/usr/pkg/include -I/usr/pkg/include -c main.cpp
In file included from toplevel.h:13,
                 from main.cpp:11:
view.h:7: QwSpriteField.h: No such file or directory
In file included from view.h:8,
                 from toplevel.h:13,
                 from main.cpp:11:
sprites.h:6: QwSpriteField.h: No such file or directory

When I make qt1 and install it, there is no QwSpriteField.h in
/usr/X11R6/qt1/include, even though it still exists in

Yes, I even manually deleted all packages that kde1 relies on and
have tried rebuilding from ground zero several times.

What happened to QwSpriteField.h and what is the best way to deal
with the problem (other than copying it and it's sibling missing
files from /usr/X11R6/include/qt to /usr/X11R6/qt1/include).