Subject: another update challenge ... ;((
To: None <>
From: Georges Heinesch <>
List: tech-pkg
Date: 05/24/2001 18:16:48

A while ago, I sup'd the pkgsrc tree. I fetched pkglint (2.44 at that
time), but didn't install it.

# cd /usr/pkgsrc/pkgtools/pkglint
# make fetch-list | sh

No it was installed in the /usr/pkgsrc/distfiles directory.

Other packages were fetched, but installed. perl-mk-1.0 was one of

Now I sup'd again, and tried to install pkglint. The version by now
was already 2.54.

perl-mk-1.0 was sufficiant for pkglint 2.44. However pkglint 2.54
requires perl-mk-1.1.

# cd /usr/pkgsrc/pkgtools/pkglint
# make install

... fails because perl-mk-1.1 is not installed (perl-mk-1.0 is

# cd /usr/pkgsrc/pkgtools/pkglint
# make update

... is not possible since pkglint was never installed before.
(I didn't try it [dared to try it])

What shall I do to install pkglint 2.54 and updating the required
perl-mk-1.0 package?


Cu  Georges Heinesch, Luxembourg
    PGP RSA & DH/DSS public key on request and on public servers

... niammi niammi in my Tammi ...