Subject: Re: Some questions on KDE2
To: Ingolf Steinbach <>
From: Nick Hudson <>
List: tech-pkg
Date: 05/21/2001 19:57:35
Ingolf Steinbach wrote:
> Hi,
> before I file PRs, I'd like to know if others have similar
> problems with KDE2 from pkgsrc:
> 1) kmail always terminates after receiving all mail via
>    pop3. It does not issue an error message (at least I
>    did not see any, even if I started kmail from a shell).
>    After opening kmail again, the newly received mails
>    (i.e. those received just before kmail terminated) seem
>    to be completely inserted into the correct mail folders.
>    Receiving mail from a local directory works well.
> 2) artsd does not work: Even if I specify /dev/audio explicitly,
>    there is no sound. (The audio device is configured at
>    boot time.)
> 3) Sometimes konqueror hangs and cannot be closed via the
>    "Alt-F4" window menu item.
> 4) There are sometimes "drkonqi" processes running forever(?)
>    and eating up CPU cycles en masse.
> 5) Has anyone tried to update the packages to 2.1.2/2.1.1?
>    I have some difficulties: there is this lt_dlopen_flag
>    introduced in KDE's ltdl library (to be found in kdebase/
>    libltdl/ltdl.c) which is not (yet?) in the libtool package.
>    Is this sort of a hack? Should lt_dlopen_flag added to
>    the libtool package? (Note: I did not verify if there were
>    changes regarding this flag to the libtool package during
>    the last two or three weeks...)

I've not seen any of the problems you mention (some because I haven't
used that part of KDE) except for the last one... The change is not in
the current libtool cvs, but I intend to point it out to the libtool

Have you tried to see if any of your problems are