Subject: Errors in packages.
To: None <>
From: Burgess,David B. <>
List: tech-pkg
Date: 04/02/2001 15:50:30
There are a series of package problems that I resolved over the week-end:
Here's the full list:

-  kxicq and much of it's kith install everything into the /usr/pkgsrc
directory instead of into ${LOCALBASE} or ${X11BASE}.  This makes the
package very hard to use.

-  imap-uw has a couple of serious errors:
	-- The package builds a .la archive, but tries to install it as a .a .	 The
PLIST may or may not be  right, I can't remember.
	-- There is no COMMENTS file.
-  I tried building php3 with the imap options turned on; that was an
adventure.  I decided to try and build php4-imap, since it couldn't be any
-  The imap-uw failure caused the php4-imap package to fail
	--  The c-client stuff in imap-uw seems to get installed correctly.
	--  The php4 Makefile.common uses a truly odd set of defaults.  For
example, the comment implies that the options were chosen to support the
standard NetBSD packages, but several options which make php4 work better
are left out (e.g., IPv6 support).
	--  The php4 package fails since it relies on zlib, which (theoretically)
is Sun only.  I tried it anyway, and the only problem I could see was that
it doesn't install a .a or .la file.  Why is zlib marked as Sun only if it
actually mostly works in i386?  There are also a couple of ${LOCALBASE}
directories missing from the .common file.
	--  It also has to have openssl 0.9.6, which is not installed in 1.5 (but
may be in -current).  I had to have openssl because the imap-uw system
relies on openssl for the secure imap and pop services.  Even then, I ended
up symlinking the libraries that php4 relied on into the /usr/local/lib
directory (brute force works sometimes) since PHP4 didn't use the right
 	--  The openssl package still installed 0.9.5b, which is what is installed
in the base distribution (IIRC).  I changed the package info to build 0.9.6
and install it in /usr/pkg/ssl, and ended up just using the "configure nbsd"
in the work/openssl directory.  I'm not sure what all of the rest of the
package is trying to do, but 0.9.6 seems to work pretty well in 1.5.  The
pkgsrc "make install" worked fine and registered the package.  IN other
words, the only part of the package that seemed necessary was the install
code, and that was just so that it got identified in the pkg_info database.

-  horde and imp (a PHP web server framework and on-line mail package)
failed because the php-imap package couldn't be installed.

-  I know it's not commonly used, but the patches from BSDi work great on
our Apache installation, with one exception.  The frontpage module is never
identified in the patchfile, so it doesn't get built.  I added a patch line
for that, and it works fine now.  This, by the way, is a new failure - the
patches in the old versions used to make this update.

I'm going to go back and try and document all of the fixes and send-pr them

1)  To whom should I send the package fixes?  Is send-pr the only right
vehicle for these?
2)  Should I bother trying to send the frontpage updates to RTR?  They've
never added a change I've sent them and don't seem interested in actually
supporting the extensions?

Dave Burgess