Subject: Re: version of unzip required in BUILD_DEPENDS?
To: Simon Burge <firstname.lastname@example.org>
From: Alistair Crooks <email@example.com>
Date: 04/02/2001 09:58:33
On Sat, Mar 31, 2001 at 12:46:09PM +1000, Simon Burge wrote:
> I went to install a package today that has a zipped distfile, and
> discovered my faithful old unzip 5.41 is no longer up to the task.
> bsd.pkg.mk now says that I need 5.42:
> thoreau:/NetBSD/pkgsrc/mk 14930> grep unzip bsd.pkg.mk | head -1
> BUILD_DEPENDS+= unzip-5.42:../../archivers/unzip
> Looking at the changes between the two versions, there doesn't appear
> to be much of a reason to say we need the latter version, but 5.40
> definitely looked bad. Anyone mind if I change that to unzip>=5.41
> (which seems to work ok as a local change here)?
> Granted, it's not much of an effort to update to a new unzip, but this
> is more of a (little) gripe about needless updating of (dependancies on)
> Anyways, I feel better after that outburst :-)
You're correct that any version of unzip should work, so we should relax
the pattern to be
(if only to emphasise the recent changes to BUILD_DEPENDS which were made).
Personally, I believe it's a small price to pay to ensure that a libtool
upgrade doesn't force you to recompile any package built with libtool.
But I'm a tad biased.
There may well be other packages like this - if you do find any, please
send-pr them in the usual way.