Subject: Re: version of unzip required in BUILD_DEPENDS?
To: Simon Burge <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 03/30/2001 21:40:39
On Sat, 31 Mar 2001, Simon Burge wrote:

> I went to install a package today that has a zipped distfile, and
> discovered my faithful old unzip 5.41 is no longer up to the task.
> now says that I need 5.42:
> 	thoreau:/NetBSD/pkgsrc/mk 14930> grep unzip | head -1
> 	BUILD_DEPENDS+=         unzip-5.42:../../archivers/unzip
> Looking at the changes between the two versions, there doesn't appear
> to be much of a reason to say we need the latter version, but 5.40
> definitely looked bad.  Anyone mind if I change that to unzip>=5.41
> (which seems to work ok as a local change here)?

I don't thank anyone would mind. What you're seeing is minor fallout
from the change in BUILD_DEPENDS' semantics. Up until last week, any
"unzip" in the path would have done.