Subject: Re: Kerberos in pkgsrc
To: Johnny C. Lam <>
From: Tracy J. Di Marco White <>
List: tech-pkg
Date: 03/30/2001 11:48:51
}> Why do you need OpenSSL for Kerberos 4? The older systems didn't have
}> it, but linked with some other libdes.
}I think I didn't explain clearly.  I was asking if we should have
}USE_KERBEROS, or perhaps new variables USE_KERBEROS{4,5} that trigger
}the installation of kth-krb4 and heimdal if the equivalents aren't
}present in the base system.  This would be much like how USE_SSL
}triggers the installation of openssl on systems where it isn't present
}in the base system.  It would be kind of tricky if there was a MIT
}Kerberos V implementation in the base system, like I think recent
}versions of Solaris have.  In this case, I'm inclined to say, "This is
}the NetBSD Packages Collection, so we'll just assume Kerberos V ==

Older versions of NetBSD (i.e. 1.4 at least) may have been using
krb-kth or MIT K4, depending on us or international.

Tracy J. Di Marco White
Project Vincent Systems Manager