Subject: Re: Undefined symbols using kde package from 1.5?
To: Frederick Bruckman <>
From: Scott Presnell <>
List: tech-pkg
Date: 03/14/2001 14:06:40
Frederick Bruckman wrote:
> On Wed, 14 Mar 2001, Scott Presnell wrote:
> > Frederick Bruckman wrote:
> > > I still don't quite understand what went wrong. What packages
> > > (filenames or url's please) did you install that gave the errors?
> >
> > I was working on a freshly installed machine so I installed the meta
> > package kde-1.1.2.
> Did you let it download the dependencies automatically?

Yes. using PKG_PATH

> > To the best of my knowledge from reports in the linux world it
> > was a problem in the intra-library calls between qt1 and
> > kdelibs.   The other package implied in this process was
> > qwspritefield. Some change in qt1 seems to be the root of the
> > problem; anything directly depedent upon qt1 is suspect.
> But qt1 has been at 1.44 since before NetBSD-1.5 was released, so
> sorry for being thick, but it's still not clear to me which binary
> packages are defective.

If that's the case, then perhaps a tool chain change?

I rebuilt and installed in order (I think) qt1, qwspritefield, kdelibs,
kdesupport, kdebase.

At that point I tested a couple of programs (kdm, kdmconfig), and got
a satisfactory response, so I continued to build the rest of the kde
packages. That's as far as I tried to narrow it down.


	- Scott