Subject: Re: new message digest support in pkgsrc
To: Todd Vierling <>
From: Thomas Klausner <>
List: tech-pkg
Date: 03/07/2001 16:22:21
Mutt made me believe that Todd Vierling wrote:
> On Wed, 7 Mar 2001, Frederick Bruckman wrote:
> : There _IS_ a problem now. Just "pkg_delete digest", revert your
> : pkg_install to NetBSD-1.5's, and try to install either package.
> Right; we'd always been able to update pkg_install, but the addition of
> "digest" made that impossible.  It's been hacked to work by wiz, for the
> moment.

Actually, the patch for that was by Alistair Crooks -- it's the same
hack used for pkg_install to be independent on what pkgtools version
is currently installed.

Before, there was a circular dependency of pkg_install and digest, but
now linearity has been restored (with digest being independent of
anything, and pkg_install only depending on digest being uptodate).

All should be working fine now.

Thomas Klausner -
To live for some future goal is shallow. It's the sides of the mountain
that sustain life, not the top. -- Robert M. Pirsig