Subject: Re: new message digest support in pkgsrc
To: Todd Vierling <>
From: Frederick Bruckman <>
List: tech-pkg
Date: 03/07/2001 09:11:47
On Wed, 7 Mar 2001, Todd Vierling wrote:

> On Wed, 7 Mar 2001, Frederick Bruckman wrote:
> : > No, the bump of the pkg_install tools caused problems. It has nothing to do
> : > with the introduction of digest.
> :
> : There _IS_ a problem now. Just "pkg_delete digest", revert your
> : pkg_install to NetBSD-1.5's, and try to install either package.
> Right; we'd always been able to update pkg_install, but the addition of
> "digest" made that impossible.  It's been hacked to work by wiz, for the
> moment.

Ah. I just updated pkgsrc/mk, pkgsrc/pkgtools/pkg_install,
pkgsrc/pkgtools/digest and successfully updated both tools on a 1.4.3
system with only minor wierdness: "make checksum" failed over to after downloading from the first time,
and failed (of course), but then, the second time, "make checksum"
worked, and the package built OK.