Subject: Re: new message digest support in pkgsrc
To: Frederick Bruckman <>
From: Todd Vierling <>
List: tech-pkg
Date: 03/07/2001 09:45:11
On Wed, 7 Mar 2001, Frederick Bruckman wrote:

: > No, the bump of the pkg_install tools caused problems. It has nothing to do
: > with the introduction of digest.
: There _IS_ a problem now. Just "pkg_delete digest", revert your
: pkg_install to NetBSD-1.5's, and try to install either package.

Right; we'd always been able to update pkg_install, but the addition of
"digest" made that impossible.  It's been hacked to work by wiz, for the

All of this doesn't explain well the separate nature of digest (and even why
it's statically linked)... since it's used solely for generating checksums
for package registration, it really belongs in pkg_install as a companion to
pkg_create.  That just seems quite natural.

-- Todd Vierling <>  *  Wasabi NetBSD:  Run with it.
-- NetBSD 1.5 now available on CD-ROM  --