Subject: Re: mysql-client
To: Michael Richardson <>
From: Todd Vierling <>
List: tech-pkg
Date: 02/24/2001 21:02:03
On Sat, 24 Feb 2001, Michael Richardson wrote:

:   I think that we should explicitly put --with-mit-pthreads  in so that
: it won't try and use Unix domain sockets. While -h/--host works for the
: command line tools, it fails for
:   Unless there is an objection, I'll commit that.

Huh?  MySQL works fine with Unix domain sockets, or at least, it did the
last time I used it.  If has a problem, that's PHP's deal.
Don't add a workaround for something that isn't broken.

:   I was unable to get apache to load because of
: dependancy without putting LD_LIBRARY_PATH=/usr/pkg/lib:/usr/lib into
: apachectl... I would have thought -R would have done enough.

-R was added to the link line for  (Have you checked to make
sure the linker's really getting the option?)

Granted, forcing dependency on libgdbm is bogus anyway, but I didn't get
involved in the php4 module, which probably needs serious cleanup.

-- Todd Vierling <>  *  Wasabi NetBSD:  Run with it.
-- NetBSD 1.5 now available on CD-ROM  --