Subject: libtool conflicts [was: Re: CVS commit: pkgsrc]
To: Dieter Baron <>
From: None <>
List: tech-pkg
Date: 02/18/2001 06:26:54
On Sat, 17 Feb 2001, Dieter Baron wrote:
> > >   When upgrading from the old version of libtool, libtool-base
> > > installs with a lot of warnings about overwriting files.  Manually
> > > removing the old libtool first fixed it, but since this was pulled in
> > > via dependencies, the cause of the problem was not immediatly
> > > apparent.  Maybe a CONFLICTS with the old package would be in order?
> >
> > How did you upgrade exactly?
>   I had libtool-1.3.5nb9 installed, did a CVS update and a make in
> some package that depended on libtool.  This pulled in the new libtool
> package, which in turn pulled in libtool-base, which installed and
> complained about overwriting files.

OK, can you please sanity-check that adding this to libtool/Makefile
(only) is enough:

CONFLICTS+=	libtool<1.3.5nb11

  - Hubert

Hubert Feyrer <>