Subject: Re: ucd-snmp: doesn't bind to port 161
To: None <>
From: Berndt Josef Wulf <>
List: tech-pkg
Date: 02/08/2001 01:29:40
Berndt Josef Wulf wrote
> G'day,
> is anyone using ucd-snmp-4.1.2? I've built this package on two
> systems, netbsd-1.5-i386 and netbsd-1.5-alpha, and both won't listen
> to port 161. I've tried to specify a port with the -p option, but no
> luck either... snmp clients trying to connect to this port time out
> and telnet sessions to this port are refused.... 
> Older versions of ucd-snmp worked on both systems... 
> Any ideas?

Hmm, I believe to have the problem... ucd-snmpd is configure to look
for mibs in

There appear to be some bugs in the mibs supplied with the scotty
package which compromised the operation of the snmpd daemon.

	e.g. inconsisting naming convention when refering to
	rfc1213.mib, undefined reference to ObjectSyntax
	etc. e.g.

ucd-snmp appears to work fine after temporarily renaming the
tnm-2.1.10/mibs directory.

My question, why does ucd-snmpd need the mibs that come with scotty?

cheerio Berndt
Name    : Berndt Josef Wulf            | +++ With BSD on Packet Radio +++
E-Mail  :             |    tfkiss, tnt, dpbox, wampes
ICQ     : 18196098                     |  VK5ABN, Nairne, South Australia 
URL     : | MBOX :
Sysinfo : DEC AXPpci33+, NetBSD-1.5    | BBS  : vk5abn.#lmr.#sa.aus.oc