Subject: openssl build problems
To: None <>
From: Ingolf Steinbach <>
List: tech-pkg
Date: 01/16/2001 12:45:42

Am I the only one who has problems building security/openssl?
This is the output of make patch:

===> Validating dependencies for openssl-0.9.5a
=> Checksum OK for openssl-0.9.5a.tar.gz.
===> Extracting for openssl-0.9.5a
===> Required installed package perl-5.*: perl-5.00404 found
===> Patching for openssl-0.9.5a
/bin/mkdir -p /usr/pkgsrc/security/openssl/work.m68k/.patches
for FILE in /usr/pkgsrc/security/openssl/patches/patch.netbsd-*; do  /bin/cp $FILE /usr/pkgsrc/security/openssl/work.m68k/.patches/patch-${FILE##*-};  done
===> Applying NetBSD patches for openssl-0.9.5a
Patch file /usr/pkgsrc/security/openssl/work.m68k/.patches/patch-aa has been modified
Ignoring unknown patch file: /usr/pkgsrc/security/openssl/work.m68k/.patches/patch-ab

{The same for patch-a[cdefgh]}

Patching failed due to modified patch file(s):  patch-aa
*** Error code 1


This was on amiga; the same happens on sparc -- both 1.5.
/pkgsrc/mk is up to date.


Ingolf Steinbach        Balin@IRCnet         ICQ#60829470
PGP: 0x7B3B5661  213C 828E 0C92 16B5  05D0 4D5B A324 EC04