Subject: Re: pkgsrc reorg proposal II
To: None <email@example.com, firstname.lastname@example.org>
From: Alistair Crooks <email@example.com>
Date: 01/04/2001 07:48:53
On Wed, 3 Jan 2001 05:25:34 +0100 (MET), firstname.lastname@example.org wrote:
> 0. Initial proposal:
> 1. Refined proposal:
> old filename new filename variable
> patches/patch-* -> patch-* PATCHDIR
> files/md5 -> dist-sum MD5_FILE
> files/patch-sum -> patch-sum PATCH_SUM_FILE
> pkg/PLIST* -> plist* PLIST_SRC
> pkg/COMMENT -> comment COMMENT
> pkg/DESCR -> descr DESCR_SRC
> pkg/INSTALL -> install INSTALL_FILE
> pkg/DEINSTALL -> deinstall DEINSTALL_FILE
> pkg/MESSAGE -> message MESSAGE_FILE
> scripts/* -> * SCRIPTDIR
> files/* -> *  -
>  Where possible - there are a number of pkgs that have a
> or similar. Must be renamed to prevent clash.
> 2. Procedure:
> The idea is to drop what's not needed of the current repository, and
> start a new one. We have two ways here:
> a) Checkout, reorg, import our ~1800 pkgs.
> This approach will also drop all revision history.
> b) Copy over all the ,v files (that are not in Attic) into a new
> repository, then reorg there. This approach will keep revision
> history of the files that are not deleted, but still speed up
> "cvs update" later as there are no Attic directories that are
> first created and then removed again immediately.
> My preference here is b).
> - Hubert
> Hubert Feyrer <email@example.com>
But how do you differentiate, using the noemnclature above, between a script
called install, and (what is currently) a pkg/INSTALL file?
Alistair Crooks (firstname.lastname@example.org)
Send a cool gift with your E-Card