Subject: Re: DEPENDS: -* or -[0-9]*
To: None <>
From: None <>
List: tech-pkg
Date: 12/07/2000 00:20:03
>On Wed, 6 Dec 2000, Dr. Rene Hexel wrote:
>>   I don't know any from the top of my head, but sometimes xxx-* means
>> 'xxx-[0-9]*' or 'xxx-current-[0-9]*'.
>> >         If not, I'll take a pass through pkgsrc and switch all the
>> >         DEPENDS and CONFLICTS to -[0-9]*.
>>   Do that, but you may want to counter-check those packages where a
>> -current exists.  For most packages this should be a non-issue, because
>> most (if not all) of these packages install their '-current' version as
>> 'package-<version>' (where <version> is a newer version than the base
>> package) anyway.
>Right, and packages that actually have a "-current" in PKGNAME should be

right now there is a cad/verilog and cad/verilog-current package.  They
install as



verilog-current-20000805  (or whatever the latest is)

I specifically did this because the snapshot releases are labeled by the
datecode (by the author) and the release releases are labeled by the
version code.

At the moment, no packages depend on verilog, but what I'd hate to see is
a situation where a package needs

DEPENDS+=	verilog>=1.0

and the package system pickup 'verilog-20000805' (if we change the name to
drop the '-current' as being >= 1.0 when in fact it isn't.  

The other thing I'd like to avoid is doing things like calling the
snapshot packages things like verilog-0.3.20000805 (meaning a snapshot
from 20000805 post version 0.3) because there is potential for conflict if
for some reason a released 0.3.1 comes out.   In fact we have a case of a
different package where 3.4beta7 (ie 7th beta version before 3.4 was
released) was entered as 3.4.7 in pkgsrc.  so when 3.4.2 and later 3.4.3
came out (which were not compatible with 3.4beta7), a depends of >=3.4.2
wasn't possible since users might have this bogus 3.4.7 installed.

I'm open to suggestions if people don't like '-current' in PKGNAME, but I
just wanted to mention the concerns I have.