Subject: Re: net/ppp package borken
To: None <>
From: Thor Lancelot Simon <>
List: tech-pkg
Date: 11/13/2000 19:50:28
On Tue, Nov 14, 2000 at 12:23:36AM +0100, wrote:
> > As it stands, naive users will probably break both their 1.4.3 and 1.5
> > installations by installing this package, for example; while the code
> I can only speak for 1.5, but the net/ppp package works fine on
> 1.5_BETA2/i386. If it didn't, you wouldn't see this.

FSVO "works".  Users who install the net/ppp package will end up
downgrading their pppd binary by a major version from what we ship as
part of the operating system, and almost certainly won't realize that
they've done so.  This is *precisely* what we need to collaborate better
to avoid; once more, I'd like to ask that more effort be spent in 
coordinating packages of this type (if they must exist) with the other
NetBSD developers so that this kind of version skew does not occur.

A simple file like "doc/DUPLICATED" in the spirit of "doc/3RDPARTY"
listing all duplication of code between the base distribution and pkgsrc
might be a good start.

Thor Lancelot Simon	                            
	the effort to perceive simply the cruel radiance of what is