Subject: Re: Mozilla Milestone 18
To: Jeremy C. Reed <>
From: Martin Husemann <>
List: tech-pkg
Date: 10/14/2000 09:30:07
> ==> mozilla-0.m18 depends on package: ORBit>=0.5.1
> ===> Verifying reinstall for ../../net/ORBit
> ===> Configuring for ORBit-0.5.3nb1
> I am receiving:
> checking for GNU xgettext... configure: error: 
> *** GNU gettext is required. The latest version
> *** is always available from
> configure: error: ./configure failed for popt
> *** Error code 1

This is a problem in installing net/ORbit (which is required by mozilla),
not a mozilla problem.

> Installed is:
> ORBit-0.5.0         high-performance CORBA ORB with support for the C language
> gettext-0.10.35     tools for providing messages in different languages
> gettext-0.10.35nb1  tools for providing messages in different languages

You did (at some point in time) force the installation of a newer version of 
gettext, without removing (or updating) the old one. This is a Bad Thing (tm).

The only way I know of how to recover from this is to do 

  pkg_info gettext-0.10.35

and note the list of packages this one is required by. Then pkg_delete -r
it. Then check if the newer one is still OK (or maybe just do an update
in net/ORbit). Then reinstall all the pkgs now gone (from the list noted