Subject: Re: Libtool on NetBSD/ELF
To: Steinar Hamre <>
From: Nick Hudson <>
List: tech-pkg
Date: 10/02/2000 13:43:54
Nick Hudson wrote:
> It looks as though you are using the 1.3.5 distribution which does have
> problems for NetBSD.
> Steinar Hamre wrote:
> > Ok, everyone hates libtool for always beeing so wrong. But we still
> > have to fix it. libtool -module on netbsd/elf creates an 'ar'-archive,
> > and *wow* that does not work with dlopen(). So I've tried fixing
> > libtool on netbsd/elf a little bit. It would be very nice if somebody
> > told me if I'm doing anything awfully wrong before i send this to the
> > libtool maintainers.
> >
> > First,echo __ELF__ | $CC -E - | grep __ELF__is true if the the
> > toolcain is *not* elf. So the first test was inversed.
> This is fixed in the pkgsrc libtool.

Should say pkgsrc and cvs repository.