Subject: a DEPENDS question
To: None <>
From: None <>
List: tech-pkg
Date: 06/30/2000 17:17:42
I knew sooner or later this would bite....

for some time, the pvm package existed in pkgsrc as 'pvm-3.4.7',
unfortunately it was really 3.4_BETA7.  Ie, pre-3.4

Next we had pvm-3.4.2 (2nd patch release to 3.4) which was newer than
3.4.7.  Scilab needed the newer one.  So scilab has:

DEPENDS+=       pvm-3.4.2:../../parallel/pvm3

I'm about to update pvm to 3.4.3.  I'd like to be able to do

DEPENDS+=       pvm>=3.4.2:../../parallel/pvm3

but that has the potential to pickup the poorly numbered 3.4.7.

So should I just force the version to be 3.4.3 or is there another way of
listing this depends?  I want "pvm(>=3.4.2 && !=3.4.7)"