Subject: Re: CVS commit: pkgsrc
To: NetBSD Packages Technical Discussion List <>
From: Berndt Josef Wulf <>
List: tech-pkg
Date: 05/29/2000 11:54:58
Greg A. Woods wrote
> [ On Sunday, May 28, 2000 at 05:32:17 (-0500), Richard Rauch wrote: ]
> > Subject: Re: CVS commit: pkgsrc
> >
> > Possibly the dependancies are made so tight because that's all that the
> > pkg creator is able to test?  It _is_ a serious problem, I agree.
> > 
> > The problem, I think, is that creators of pkgsrc dependancies have to
> > choose between being lax (risking the construction of packages that don't
> > work, or that have subtle problems) vs. being too strict (requiring extra
> > updates of packages).  I suspect that not many pkg creators are in a
> > position to really test out which versions are required, and simply record
> > the versions that _they_ have and that _they_ believe to work.
> > 
> > If you believe that a restriction is too tight, perhaps you cand send-pr a
> > patch to the package?
> You can't make much choice when you're using shared libraries without
> having intimate knowledge of the API of the library (something pkgsrc
> maintainers should *not* have to trouble themselves with).
> However if all packages were statically linked with all non-system
> libraries then you don't even have to declare any install or runtime
> dependencies at all in the first place -- just build-time ones.

Whilst this may be true in case of libraries, it isnt' for
applications. In my example, most applications will work with any
version of GS and in this case there is no need of forcing a user to

Here a concrete example of what I did with XV

-DEPENDS+=       ghostscript{,-nox11}-[6-9]*:../../print/ghostscript
+DEPENDS+=       ghostscript{,-nox11}-[5-9]*:../../print/ghostscript

giving me the following output

===> xv-3.10apl1 depends on installed package:
ghostscript{,-nox11}-[5-9]* - ghostscript-5.50 found

I've used the revision number for GS5 installed on my system but
it may well be GS3 or GS4...

In case of XV, it will support ghostscript =>2.6 see the config.h

* PostScript file input support:
* if you have the 'ghostscript' package installed (version 2.6 or later.)
* XV can use it to read and display PostScript files.

Why forcing users to upgrade if older versions work? 

I use the example of XV here because it was mentioned in one of the
earlier postings in respect to ghostscript, but this applies to any
other package. I believe that it should be the package maintainer's
responsibility to decide on the revision threshold levels for interdependencies
on external applications/libraries and not the person updating an
existing package as it is impossible for anyone to know the
requirements of all packages affected.

cheerio Berndt
Name    : Berndt Josef Wulf            | +++ With BSD on Packet Radio +++
E-Mail  :             |    tfkiss, tnt, dpbox, wampes
ICQ     : 18196098                     |  VK5ABN, Nairne, South Australia 
URL     : | MBOX :
Sysinfo : DEC AXPpci33+, NetBSD-1.4.2  | BBS  : vk5abn.#lmr.#sa.aus.oc