Subject: Re: make update
To: Jukka Marin <>
From: Andrew Gillham <>
List: tech-pkg
Date: 05/12/2000 13:53:54
Jukka Marin writes:
> Hello,
> I like the package system.
> BUT upgrading packages always drives me grazy.  Yesterday, I wanted to install
> AbiWord.  Fine.  My libpng was too old, pkgsrc wanted to upgrade it.  Fine.
> libpng is used by KDE, xv, gimp, etc.  All of these were deinstalled.  Now
> KDE fails to build (missing Qt header file or some such) and I'm left with
> a system without ANY graphics package using libpng.
> And all I wanted to do was to install AbiWord, not to upgrade or delete
> anything.  I guess it'll take the whole day to get everything back in
> order again..

Heh, I can't count the number of times I've rebuilt KDE because of this.
Just "updating" apache touchs tons of packages also.
I guess the 'force package register' option is perhaps what should be 
done in this case.

I usually will end up run pkg_delete for *everything*, and starting over
from scratch.  What I should be doing is building a binary package and just
re-installing that I guess.

I still don't have the newest AbiWord installed on all of my machines. :(

Andrew Gillham                            | NetBSD ist Affengeil.                     | Nachts ist es kaelter
I speak for myself, not for my employer.  | als draussen.