Subject: Re: py-postgresql package
To: Brook Milligan <>
From: D'Arcy J.M. Cain <>
List: tech-pkg
Date: 02/23/2000 11:26:55
Thus spake Brook Milligan
> I'm trying to compile the py-postgresql package and get the following
> error:
> ===>  Building for py-postgresql-2.4
> ld -Bshareable  pgmodule.o  -Wl,-R/usr/pkg/pgsql/lib -L/usr/pkg/pgsql/lib -lpq -lcrypt -o
> ld: invalid command option `-Wl,-R/usr/pkg/pgsql/lib'
> *** Error code 1
> Is this an elf-transition problem?  What options should the loader be
> using?

Yes, I did this on an ELF system but I was told that this would still
work on a COFF system.  Obviously not.  Can anyone fix this without
breaking ELF builds?  Some sort of ifdef in the make file perhaps?

D'Arcy J.M. Cain <darcy@{druid|vex}.net>   |  Democracy is three wolves                |  and a sheep voting on
+1 416 425 1212     (DoD#0082)    (eNTP)   |  what's for dinner.