Subject: Re: Maxi-packages
To: Gavan Fantom <firstname.lastname@example.org>
From: Rene Hexel <email@example.com>
Date: 02/04/2000 20:43:20
Gavan Fantom wrote:
> How about providing the options MINIMAL_DEPENDS and INTERACTIVE_DEPENDS in
> mk.conf. The current way of doing things would be represented by
> MINIMAL_DEPENDS=NO and INTERACTIVE_DEPENDS=NO. The meaning of
I remember that we had a similar discussion some time ago.
IMHO, the major obstacle to such a solution is that we would need some
kind naming scheme to distinguish binary packages that have been built
with different sets of options. Also, things get even more complicated
if some package depends on such a package, but requires that some
options be present (and even worse, maybe, that some options are not
set). This all tends to evolve into a very complex scenario ...