Subject: Re: PGP
To: Bjoern Labitzke <>
From: D'Arcy J.M. Cain <>
List: tech-pkg
Date: 01/31/2000 10:44:57
Thus spake Bjoern Labitzke
> * D'Arcy J.M. Cain ( [000131 07:23]:
> | Anyone got PGP working from pkgsrc?  I see pgp2 and pgp5 but both of
> | them fail to work.  It seems that pgp5 needs to have the elm sources
> | patched but the patch file is for PL34 and we have PL54 in the tree.
> | Any help appreciated.
> Yes, PGP5 works fine here. But I haven't tried to rebuild
> it lately. What kind of problems do you see? What fails and
> how? PGP definitely does not depend on elm in any way.

When I run pgp2 I get this.

Running pgp: Checking signature...
ERROR: Header line added to ASCII armor: "Hash: SHA1"
ASCII armor corrupted.

Error: Transport armor stripping failed for file pgptemp.$00

pgp5 requires name changes.  Elm looks for pgp but it needs to be pgpv.
You can't just change the name in elmrc though because there are other
names.  The patch to elm is to call different programs by adding the
proper trailing letter and modifying the args.

I tried manually patching elm but that didn't work either.  It seemed
to still be looking for the old program name.  There must be something
else that the patch doesn't deal with.

I guess this is really an elm question, not a pgp question.

D'Arcy J.M. Cain <darcy@{druid|vex}.net>   |  Democracy is three wolves                |  and a sheep voting on
+1 416 425 1212     (DoD#0082)    (eNTP)   |  what's for dinner.