Subject: Re: amanda
To: None <>
From: maximum entropy <>
List: tech-pkg
Date: 01/22/2000 12:54:13
>Date: Sat, 22 Jan 2000 12:46:02 -0500
>From: Bill Squier <>
>Actually, even my correction to the patch is b0rked.  It will cause amanda to 
>break for <= 1.4.1.
>It should conditionally use the new ioctl and struct based on the value of 

Is this really a problem?  I thought that -current pkgsrc was really
only expected to compile and run on -current, while users of releases
would use the pkgsrc distributed with their release.

I applied your patch last night by hand, and got it to compile (but I
haven't tested it yet).

I'd be happy to work up a patch based on your work, adding
conditionals on __NetBSD_Version__, if that's what it would take to
get the patch committed.