Subject: qt2
To: Matthias Drochner <>
From: Thomas Klausner <>
List: tech-pkg
Date: 01/17/2000 16:53:36

Mutt made be believe that Matthias Drochner wrote:
> The problem is even worse for qt: There is qt-2.x out for quite
> a while, and people (at least me) would like to base new developments
> on it. The current usable KDE depends on qt-1.x, and I'd
> consider it practically impossible to get it working with 2.x.

In this case I propose renaming the current qt-directory to qt1, but
let it's name still be qt-1.x. Then we change all the dependencies,
and make a new package qt, which really is qt-2.x. We also will have
to make those two packages conflict each other. If someone is
motivated enough, he can make qt1 install its headers and libraries
into a separate directory and fix all packages which depend on qt1 to
find those headers/libs only. qt2 libraries should just install in the
default locations, since most new programs will rather use qt2 instead
of qt1. If some programs work with either version, we can let them
depend on qt-*.



Thomas Klausner -
Programming is like sex:
  One mistake and you have to support for a lifetime.