Subject: Re: tcl split [was: Re: CVS commit: pkgsrc]
To: None <>
From: Matthias Drochner <>
List: tech-pkg
Date: 01/10/2000 15:48:38 said:
> tcl-8.2.3. Too much problems when attempting to keep multiple versions
> of one package - out pkg system is just not designed for that. 

That's too much trouble, at least for me. There are at least
40 packages depending on tcl/tk-8.0, and there are changes
between tcl-8.0 and 8.2 which can break backwards compatibility.
Unless someone does all the work of checking and patching, we have
to keep tcl80 around.
And if we don't allow coexistence: Why do we go through all this
trouble with include/tcl8.0/ et al. version dependant subdirs, which
breaks almost every automatic configuration script - for nothing?

best regards