Subject: Re: USE_INET6 idea, fixed
To: None <>
From: Todd Vierling <>
List: tech-pkg
Date: 01/08/2000 18:47:33
On Sun, 9 Jan 2000 wrote:

: 	The above proposal is just fine, except tricky situation with
: 	"latest pkgsrc on 1.4 branch" - some of packages bark if there's no
: 	getaddrinfo(3).

The latest pkgsrc *should* build on 1.3 (actually, 1.3.2).  See below:

: 	Is it correct that you are saying binary package builders/people
: 	compile packages need to set HAS_INET6 in mk.conf, if they are working
: 	on 1.5?  Or will it be automatically defined by trick?
: 	(like exit status from "ifconfig lo0 inet6")

Automatically defined.  This means that a 1.3/1.4 user would point out a
build needing HAS_INET6 ("good programs" should not need it :).  The extra
code for programs that auto-adapt IPv4/IPv6 is small enough.

-- Todd Vierling (