Subject: libtool question
To: NetBSD packages <>
From: Bjoern Labitzke <>
List: tech-pkg
Date: 01/03/2000 19:54:51

Finally I am updating the Tcl package. Or rather trying to... I took the
existing package as an example how to do it, but I have got a problem:

In addition to the library there exists a library called The former requires the latter. Right now I try to
build them like this:

	${LIBTOOL} --mode=link ${CC} -o ${} ${OBJS:.o=.lo} ${} -rpath ${PREFIX}/lib -version-info 1:0

	${LIBTOOL} --mode=link ${CC} -o ${} ${STUB_LIB_OBJS:.o=.lo} -rpath ${PREFIX}/lib -version-info 1:0

But here I get the following error:

cc -shared -Wl,-soname -Wl, -o .libs/ tclStubLib.lo
(cd .libs && ln -s
(cd .libs && ln -s
ar cru .libs/libtclstub82.a tclStubLib.o
ranlib .libs/libtclstub82.a
(cd .libs && ln -s ../
/usr/pkg/bin/pkglibtool-ELF-1.2p2  --mode=link cc -o regcomp.lo regexec.lo regfree.lo regerror.lo tclAlloc.lo tclAsync.lo tclBasic.lo tclBinary.lo tclCkalloc.lo tclClock.lo tclCmdAH.lo tclCmdIL.lo tclCmdMZ.lo tclCompCmds.lo tclCompExpr.lo tclCompile.lo tclDate.lo tclEncoding.lo tclEnv.lo tclEvent.lo tclExecute.lo tclFCmd.lo tclFileName.lo tclGet.lo tclHash.lo tclHistory.lo tclIndexObj.lo tclInterp.lo tclIO.lo tclIOCmd.lo tclIOSock.lo tclIOUtil.lo tclLink.lo tclListObj.lo tclLiteral.lo tclLoad.lo tclMain.lo tclNamesp.lo tclNotify.lo tclObj.lo tclPanic.lo tclParse.lo tclParseExpr.lo tclPipe.lo tclPkg.lo tclPosixStr.lo tclPreserve.lo tclProc.lo tclRegexp.lo tclResolve.lo tclResult.lo tclScan.lo tclStringObj.lo tclThread.lo tclStubInit.lo tclStubLib.lo tclTimer.lo tclUtf.lo tclUtil.lo tclVar.lo tclMtherr.lo tclUnixChan.lo tclUnixEvent.lo tclUnixFCmd.lo tclUnixFile.lo tclUnixPipe.lo tclUnixSock.lo tclUnixTime.lo tclUnixInit.lo tclUnixThrd.lo tclUnixNotfy.lo tclLoadDl.lo!
! -rpath /usr/pkg/lib -version-info 1:0
pkglibtool-ELF-1.2p2: link: libtool library `' may not depend on uninstalled libraries:
*** Error code 1

I have no idea, how to solve this. Any help appreciated. (BTW: I know that
Tcl/Tk 8.3 is due in Febuary, but I need a newer version than 8.0 right now.
And it has to be stable.)

Bye, Bjoern

Bjoern Labitzke  <>
   Use PGP! (Don't you use envelopes for your letters?)