Subject: pkgtools ver. (was Re: My prayers have been heared!)
To: Rick Kelly <>
From: None <>
List: tech-pkg
Date: 12/16/1999 23:23:10
On Thu, 16 Dec 1999, Rick Kelly wrote:

> This has actually led me to a strange situation.
> The pkg tools seem to have stopped working.
> When I try to install suse_linux-6.1p1 from pkgsrc I get the
> interesting message:
> ===>  Validating dependencies for suse_linux-6.1p1
> Your package tools need to be updated to 1999/09/09 versions.
> The installed package tools were last updated on 1999/08/23.
> Please make and install the pkgsrc/pkgtools/pkg_install package.
> *** Error code 1
> When I do a make in: /usr/src/pkgsrc/pkgtools/pkg_install
> it compiled okay, but "make install" returns immediately
> to the shell prompt. If I cd to ./work/pkg_install and
> do a "make install", the binaries install in /usr/sbin,
> but something doesn't get updated, so it continues
> to assume that I only have package tools from 1999/08/23.

hmm,  what does

make show-pkgtools-version

say (from one of the pkgsrc/foo/bar directories)?