Subject: More KDE 1.1.2 build issues on SPARC
To: None <tech-pkg@NetBSD.ORG>
From: Greg Earle <earle@isolar.DynDNS.ORG>
List: tech-pkg
Date: 11/05/1999 19:42:02
KDE 1.1.2 requires the "kdenetwork" 1.1.2 package, and I've run aground on
trying to build that (under 1.4.1):

===>  Returning to build of kdenetwork-1.1.2
===>  kdenetwork-1.1.2 depends on installed package: kdebase-1.1.2 - \
kdebase-1.1.2  found
===>  Patching for kdenetwork-1.1.2
===>  Applying NetBSD patches for kdenetwork-1.1.2
===>  Configuring for kdenetwork-1.1.2
/usr/bin/ld -Bshareable -o .libs/ pframe.lo /usr/lib/c++rt0.o
ld: /usr/lib/c++rt0.o: illegal reloc type mix

gmake[3]: *** [] Error 1
gmake[3]: Leaving directory \
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory \
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory \
gmake: *** [all-recursive-am] Error 2
*** Error code 2


Ugh ... why is this thing trying to invoke the linker directly to create
the .so, and with /usr/lib/c++rt0.o to boot?

Any workarounds?

(No wonder the subdirectory was named "puke" ... how apropos)

	- Greg