Subject: USE_NCURSES? [was: Re: CVS commit: pkgsrc]
To: Alistair G. Crooks <>
From: Hubert Feyrer <>
List: tech-pkg
Date: 10/22/1999 13:56:37
On Thu, 21 Oct 1999, Alistair G. Crooks wrote:
> Log Message:
> Only have a pre-requisite of ncurses on NetBSD.
> To generate a diff of this commit:
> cvs rdiff -r1.11 -r1.12 pkgsrc/misc/siag/Makefile


i think you can add this for about any package that wants ncurses. 
Should we add some USE_NCURSES switch that hides these bits in 

.if defined(USE_NCURSES)
.if ${OPSYS} == "NetBSD"
DEPENDS+=      ncurses-4.2:../../devel/ncurses
.endif # NetBSD
.endif # USE_NCURSES

 - Hubert

NetBSD - Better for your uptime than Viagra