Subject: Re: Mesa-glx versus xlockmore?
To: Andrew Gillham <>
From: Mason Loring Bliss <>
List: tech-pkg
Date: 10/10/1999 17:51:29
On Sun, Oct 10, 1999 at 01:34:57AM -0400, Andrew Gillham wrote:

> It did for me.  There is an error in the pkgsrc/graphics/Mesa/Makefile
> that says "CONFLICT=" instead of "CONFLICTS=" which will cause things
> that depend on 'Mesa-*' to re-install Mesa (software only) over top of
> your Mesa-glx-* package.

Hm. I'm spinning my wheels madly here. I've tried what seems like an infinite
number of combinations of libraries and build orders, and I can't get ac-
celeration to work, it seems. I had it working once, with XFree 3.3.1 and
hand-built stuff, but I can't get it working now, with XFree 3.3.5 and
the pkgsrc Mesa-glx stuff. Tron fixed the package's CONFLICT(S) problem
earlier, but this doesn't seem to be helping me.

Two things would be fairly cool:

1) Could I bother you for copies of your /usr/X11R6/lib/libGL* and modules/

2) Could you tell me what numbers do you see with the Mesa "trispd" demo?

> What could be happening is you install Mesa-glx-tnt-*, and then build/install
> xlockmore, which causes the Mesa-3.0 to be installed.  Your end result is
> software GL again. :)

I've gone so far as to segment the build process rigidly - perhaps brutally -
so once the original Mesa stuff was installed it wasn't going to install
again, so I was definitely running the Mesa-glx-built libraries. Also, I've
verified that the server's loading the glx module:

(--) no ModulePath specified using default: /usr/X11R6/lib/modules
        GLX extension module for XFree86 -- Mesa version 3.0
                GLX package version 0.9, GLX protocol version 1.2.
(**) module successfully loaded from /usr/X11R6/lib/modules

My XFree is:

XFree86 Version 3.3.5 / X Window System
(protocol Version 11, revision 0, vendor release 6300)

I've tried this in both eight and sixteen bits per pixel. I've tried it with
hand-injected libGL.* libraries build from Riva's sources, both with Mesa
installed first and with Mesa-glx installed first. I've tried installing
Riva's stuff with none of the Mesa packages installed. I've tried having the
package use a hand-patched Mesa source tree outside of pkgsrc, patched with
the package source patches and other stuff straight from Riva.

Heartfelt thanks in advance for hints and/or help!

    Mason Loring Bliss  They also surf who
awake ? sleep : dream;  only stand on waves.