Subject: Re: Valid package names
To: Simon Burge <>
From: Hubert Feyrer <>
List: tech-pkg
Date: 09/13/1999 04:09:08
On Mon, 13 Sep 1999, Simon Burge wrote:
> I'm working on the source-code version of bladeenc, and not sure what
> the valid package name is.  At the moment, I have:
> 	DISTNAME=  bladeenc-082-src-stable-2
> 	PKGNAME=   bladeenc-0.82pl2
> and pkglink gives a fatal on the "-0.82pl2" version.  It's passes
> "-0.82" ok, but this is second patchlevel of 0.82.  Based on some
> private mail from Hubert for the postfix package, I thought that
> "N.NNN-plN" was valid - is pkglint being too strict?  Any hints?

I've just checked some package with pkglint-1.73 that I've set
PKGNAME=        bladeenc-0.82pl2
and it worked fine for me. Indeed, the version you suggest is what looks
perfect to me. Maybe upgrade your pkglint?

 - Hubert

NetBSD - Better for your uptime than Viagra