Subject: Re: perl pkg
To: Gandhi woulda smacked you <>
From: Todd Vierling <>
List: tech-pkg
Date: 08/06/1999 15:45:04
On Fri, 6 Aug 1999, Gandhi woulda smacked you wrote:

: Maybe the DEPENDS check should be passed directly to pkg_info -e,
: so you can say, i.e. 
: 	DEPENDS="perl>5.00404"

All o' ya better watch which of the seven seals you open.  ;)

There are problems with this, which is why it's not yet implemented.  For
perl in particular, binaries of compiled modules can change from one perl
version to another.  For packages in general, we need a mechanism to make
this work for binary pkgs (and remember, binary pkgs have to be able to
*fetch* as well as install their dependencies).

-- Todd Vierling (