Subject: Re: libcurses won't build
To: Frederick Bruckman <>
From: Reinoud Zandijk <>
List: tech-pkg
Date: 07/21/1999 11:37:55
Hi Frederick,

On Tue, 20 Jul 1999, Frederick Bruckman wrote:
> > Last night I tried to install www/lynx on a Sun SPARCstation-SLC, but the
> > building of the new 1.3.7 libcurses failed due to a missing archive in the
> > fetch-list.
> You mean libslang-1.3.7, right?

Ahum.... yes I think so ... sorry. Must pay more attention to it I guess.

> It's hard to figure out exactly what happened from your description.
> The libslang package downloads only one file, so if it were on the
> first server that would have been the end of it. Next time, try
> "script mklog" before "make install; exit". That will save all the
> output in the file "mklog" so you can examine it later.

Well, the log is (not from the Sun, but from an Acorn) :
  ismaelda# script mklog
  Script started, output file is mklog
  ismaelda# make
  >> slang-1.3.7.tar.gz doesn't seem to exist on this system.
  >> Attempting to fetch slang-1.3.7.tar.gz from
  Connected to
  220 space FTP server (SunOS 4.1) ready.
  331 Guest login ok, send ident as password.
  230 Guest login ok, access restrictions apply.
  200 Type set to I.
  250 CWD command successful.
  local: slang-1.3.7.tar.gz remote: slang-1.3.7.tar.gz
  227 Entering Passive Mode (18,75,0,10,6,58)
  550 slang-1.3.7.tar.gz: No such file or directory.
  221 Goodbye.
  >> Attempting to fetch slang-1.3.7.tar.gz from
  Redirected to
  2326     102.34 KB/s    00:00 ETA
  2326 bytes retrieved in 00:00 (39.25 KB/s)
And then it stopped...

> FAILOVER_FETCH=yes in /etc/mk.conf seems to work as expected. Don't
> remember exactly what happens without it.

I might try a /etc/mk.conf :-) I still don't have one since it isn't
shiped with... hmmm. there is a /usr/pkgsrc/mk/mk.conf.example ...

Well, I hope the problem is a bit clear now. I got Lynx to work, but the
cursorkeys are still not functioning properly; also in bash.