Subject: Re: dependencies
To: Mirian Crzig Lennox <>
From: David Maxwell <>
List: tech-pkg
Date: 06/24/1999 14:52:25
On Thu, Jun 24, 1999 at 09:14:24AM -0400, Mirian Crzig Lennox wrote:
> I'm a bit new to this list, so forgive me if this has been hashed out
> before...
> I've been trying to use the package system and I have noticed
> something a little irritating: If, for example, package foo depends on
> package bar-3.5.2, and I have bar-3.5.3 installed, pkg_add still
> complains that I need bar-3.5.2.  Other package systems like rpm and
> debian's dpkg seem to know that a newer minor release is as good as an
> older one.  Am I misunderstanding something here, or is that the way
> pkg_add really is supposed to work?

I wasn't following the tech-pkg list until recently, but I imagine
an argument something like this:

Each programmer has a different idea of what the digits in a release
'mean'. It's not possible to make a rule like "changing the last
digit is ok".

However, pkg creators can choose whether to allow only a specific
version, or anything >= a version. (I believe.) And it's probably
just that the person who packaged foo didn't know about the newer
version, or couldn't guarantee that it would work.

Is this pkgsrc-current or pkgsrc-1.4 ?   It may already have been

David Maxwell,| -->
All this stuff in twice the space would only look half as bad!
					      - me