Subject: Re: qpopper needs gdbm?
To: Matthias Scheler <>
From: Dean Huxley <>
List: tech-pkg
Date: 05/10/1999 17:49:04 (Matthias Scheler) wrote:
> In article <>,
> 	Christoph Badura <> writes:
> >>Should there be DEPENDS line for gdbm in the Makefile?
> > 
> > No.  The check for gdbm should be disabled in the configure scripts.
> Actually I can't see how it found "gdbm":
> ===>  Configuring for qpopper-2.53
> ...
> checking for ndbm.h... yes
> checking for gdbm.h... no
> checking for dbm.h... no
> ...
> Perhaps there is a copy "gdbm.h" in "/usr/include" on Dean's system?

Nope.  This same problem occurs on all three of my x86 boxes.  One of
them was installed from scratch a few weeks ago with 1.4BETA.  I get
the same three lines from configure as you listed above.  It's this
line that is causing my problem:

checking for gdbm_open in -lgdbm... yes

This sets '#define GDBM 1' in config.h which causes a bunch of files to
include gdbm.h.